PDA

View Full Version : corrupt $Mft 6.5TB raid (5) array


bradleyjr
5th April 2010, 09:51
OS=Windows server 2003 R2 SP2
Hardware=DNF hardware, flexstor OS and Enterprise 16320Z (affected-infected?) and two other Enterprose raid 5 arrays 16322Z.
I had to rebuild the raid array after replacing a suspect hard drive.
I completed the rebuild before using the partition recovery.

I tried the Partition recovery and completed step6 (it took two days).
I do not get a volume (NTFS-or otherwise) to select so I am unable to proceed.

Initial errors on this partition were random files corrupted and the $Mft corrupted messages. Prompted to run chkdsk. I ran chkdsk with only the affected raid 5 array disconnected while the 2 other raid arrays were active.
This of course did nothing but I had to buy my users some time with the other data.
I ran scheduled chkdsk and rebooted server when I could.
When it came up the volume that had the errors initiallywas no longer visable.
That is, the data was no longer visable to the OS.
If I tried to open it I got the message stating that the drive is not formatted, would I like to format? uh, NO!

I called the DNF technicians and they recommended your software.

If I change the view to partition table, I get some information on the first listing for partition table, it just doesn't mean anything to me.
There are 3 other listings that have no data.

I am really hoping that my user do not have to recover all of this data from LTO tape if at all possible.

PLEASE HELP!
thanks,
Janet:(

Alexey V. Gubin
5th April 2010, 13:12
Does not look like you need a RAID reconstruction. The RAID appears OK still.

Try this

1. Start ZAR
2. Click "Advanced Configuration"
3. Under "Disks and partitions" change "Disk access using physical devices" to "Disk access using logical drives".
4. Click OK to close config and proceed to the list of drives.
5. Pick the drive letter for your RAID and see if you can recover it.