ZAR data recovery forum This forum is the official point of contact for technical questions related to Zero Assumption Software products. Ordering-related questions should be directed here. The forum is monitored 13:00 - 20:00 GMT on working days. Current time is 16:07 GMT, Thursday.
 

Go Back   ZAR data recovery forum > Data recovery & support > ZAR
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

ZAR ZAR-related questions. Digital image recovery; General data recovery (filesystems and RAIDs).

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Windows software RAID

Hi !

I have a computer equiped with XP Pro SP2. The system disk is a 40 GB PATA (working).There are 2x 80 GB Maxtor SATA with Windows software RAID (striped, 3 partitions : 20 GB, 100 GB and the rest, all NTFS) for softwares and data, no system.

I upgraded the mainboard, plugged PATA and SATA and the software RAID is now corrupted (says Windows Disk Manager - Dynamic Disks : unreadable). System is OK.

It seems the mainboard was configured for AHCI disks. I disabled this function afterward. Nothing should have been written on the SATA disks (apart maybe from MBR).

I used ZAR 8.3 and after reading the forum, I defined RAID Manually (RAID 0, 128 sectors). ZAR found a ~80GB partition which I didn't have. After Scanning for Missing Partitions, ZAR found the 20 GB and 100 GB partitions along others (old ?).

Searching the 20GB partition, ZAR discovered my files but after saving them to an external HD most were unusable (pdf, zip, exe).

I tried "Reconstruct RAID layout" but got a better result defining RAID manually.

Should I try in the volume definition dialog to select "There was only one volume" for a better result or are the entered RAID parameters wrong (if that was the case I shouldn't be seeing any filename, no) ?

Thank you.
Reply With Quote
  #2  
Old 20th May 2008
Alexey V. Gubin Alexey V. Gubin is offline
Administrator
 
Join Date: Apr 2007
Posts: 2,977
Send a message via MSN to Alexey V. Gubin
Default Re: Windows software RAID

If you have RAID parameters wrong, all sorts of bizzare things may occur. This is because the data is still there somewhere, and volume tables are still there. Scanning for a missing partitions is reasonably useless if you have a RAID.

I think we better check what the LDM database contents are. What I need you to do:
  1. Delete the log file, C:\Program files\ZAR\logfile.txt
  2. Start ZAR
  3. On the first screen, click "Advanced Configuration"
  4. Make sure that under "Disks and Partitions", the setting "Read and parse LDM information" is checked (i.e. activated).
  5. Click OK to close configuration.
  6. Click "Next" until you get to the volume selection (where it prompts you to select a volume).
  7. At this point, exit ZAR. DO NOT perform the scan.
  8. Open the log file with notepad and post its entire contents here.
This way, we can see what it says about LDM database contents and condition, and (probably) get the correct parameter values from it.
__________________
Best regards,
Alexey

Last edited by Alexey V. Gubin : 20th May 2008 at 07:57. Reason: Emphasis - do NOT scan.
Reply With Quote
  #3  
Old 20th May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Re: Windows software RAID

Here it is :

--------------------
Init done - logging
NT 5.1.2600 Service Pack 2; 2046 MB RAM
Open physical drive 00000100 success, 38165 MB : WDC WD400BB-75AUA1 - Port 0, Bus 0, Target 0, LUN 0; maxLBA=78163247
Open physical drive 00000101 success, 78166 MB : Maxtor 6Y080M0 - Port 2, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000102 success, 78166 MB : Maxtor 6Y080M0 - Port 3, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000103 success, 298 GB : Maxtor 3000LE v01.00.00; maxLBA=625140736
Open physical drive 00000104 success, 4032 MB : Kingston DataTravelerCR; maxLBA=8257536
Open physical drive 00000105 success, 974 MB : Kingston Card Reader; maxLBA=1995264
Virtual RAID settings changed for Virtual RAID #0
-------------------------------------
Volume information for ID 00000201
Origin : Reconstructed RAID
Partition type : Unknown
Capacity : 152 GB
Number of sectors : 320168830
RAID type : RAID0 (Stripe set)
Stripe size : 128
Rotation parameters: 0 / 0
Member 00 : 160084415 sectors at LBA 0 on device 0101
Member 01 : 160084415 sectors at LBA 0 on device 0102
---Start S.M.A.R.T. data for device Maxtor 6Y080M0 - Port 2, Bus 0, Target 0, LUN 0, ID 0101
Attribute - Val -Worst-Thresh- Raw
Spin Up Time - 223 - 223 - 63 - 00001F94
Start/Stop Count - 253 - 253 - 0 - 000002CA
Reallocated Sectors Count - 253 - 253 - 63 - 00000000
Read Channel Margin - 253 - 253 - 100 - 00000000
Seek Error Rate - 253 - 252 - 0 - 00000000
Seek Time Performance - 253 - 243 - 187 - 000085E1
Power On Hours Count - 178 - 178 - 0 - 000000BC
Spin Retry Count - 252 - 252 - 157 - 00000001
Recalibration Retry Count - 253 - 252 - 223 - 00000000
Power Cycle Count - 252 - 252 - 0 - 0000028A
Power Off/Retract Cycle Count - 253 - 253 - 0 - 00000000
Load/Unload Cycle Count - 253 - 253 - 0 - 00000000
Temperature - 253 - 253 - 0 - 00000023
Hardware ECC Recovered - 253 - 252 - 0 - 00000319
Reallocation Events Count - 253 - 253 - 0 - 00000000
Current Pending Sector Count - 253 - 253 - 0 - 00000000
Off-Line Uncorrectable Sectors Count - 253 - 253 - 0 - 00000000
Ultra DMA CRC Error Rate - 199 - 199 - 0 - 00000000
Write Error Rate - 253 - 252 - 0 - 00000000
TA Counter Detected - 253 - 251 - 0 - 00000000
TA Counter Decreased - 253 - 252 - 0 - 00000000
Unknown attribute (203) - 253 - 252 - 180 - 00000000
Unknown attribute (204) - 253 - 252 - 0 - 00000000
Unknown attribute (205) - 253 - 252 - 0 - 00000000
Unknown attribute (207) - 252 - 252 - 0 - 00000001
Unknown attribute (208) - 253 - 252 - 0 - 00000000
Unknown attribute (209) - 197 - 188 - 0 - 00000000
Unknown attribute (99) - 253 - 253 - 0 - 00000000
Unknown attribute (100) - 253 - 253 - 0 - 00000000
Unknown attribute (101) - 253 - 253 - 0 - 00000000
--- End S.M.A.R.T. data for device Maxtor 6Y080M0 - Port 2, Bus 0, Target 0, LUN 0, ID 0101
---Start S.M.A.R.T. data for device Maxtor 6Y080M0 - Port 3, Bus 0, Target 0, LUN 0, ID 0102
Attribute - Val -Worst-Thresh- Raw
Spin Up Time - 192 - 187 - 63 - 00003B36
Start/Stop Count - 252 - 252 - 0 - 0000080C
Reallocated Sectors Count - 222 - 222 - 63 - 00000140
Read Channel Margin - 253 - 253 - 100 - 00000000
Seek Error Rate - 253 - 252 - 0 - 00000000
Seek Time Performance - 253 - 245 - 187 - 000087B4
Power On Hours Count - 136 - 136 - 0 - 00001CC1
Spin Retry Count - 253 - 250 - 157 - 00000000
Recalibration Retry Count - 253 - 252 - 223 - 00000000
Power Cycle Count - 251 - 251 - 0 - 00000370
Power Off/Retract Cycle Count - 253 - 253 - 0 - 00000000
Load/Unload Cycle Count - 253 - 253 - 0 - 00000000
Temperature - 253 - 253 - 0 - 00000029
Hardware ECC Recovered - 253 - 252 - 0 - 00000E8A
Reallocation Events Count - 253 - 253 - 0 - 00000000
Current Pending Sector Count - 253 - 253 - 0 - 00000000
Off-Line Uncorrectable Sectors Count - 253 - 253 - 0 - 00000000
Ultra DMA CRC Error Rate - 82 - 1 - 0 - 000000D9
Write Error Rate - 253 - 252 - 0 - 00000000
TA Counter Detected - 253 - 246 - 0 - 00000001
TA Counter Decreased - 253 - 252 - 0 - 00000000
Unknown attribute (203) - 253 - 252 - 180 - 00000000
Unknown attribute (204) - 253 - 252 - 0 - 00000000
Unknown attribute (205) - 253 - 252 - 0 - 00000000
Unknown attribute (207) - 253 - 250 - 0 - 00000000
Unknown attribute (208) - 253 - 252 - 0 - 00000000
Unknown attribute (209) - 202 - 198 - 0 - 00000000
Unknown attribute (99) - 253 - 253 - 0 - 00000000
Unknown attribute (100) - 253 - 253 - 0 - 00000000
Unknown attribute (101) - 253 - 253 - 0 - 00000000
--- End S.M.A.R.T. data for device Maxtor 6Y080M0 - Port 3, Bus 0, Target 0, LUN 0, ID 0102
Loading RAID ID transform
Done loading RAID ID transform
Open physical drive 00000100 success, 38165 MB : WDC WD400BB-75AUA1 - Port 0, Bus 0, Target 0, LUN 0; maxLBA=78163247
Open physical drive 00000101 success, 78166 MB : Maxtor 6Y080M0 - Port 2, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000102 success, 78166 MB : Maxtor 6Y080M0 - Port 3, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000103 success, 298 GB : Maxtor 3000LE v01.00.00; maxLBA=625140736
Open physical drive 00000104 success, 4032 MB : Kingston DataTravelerCR; maxLBA=8257536
Open physical drive 00000105 success, 974 MB : Kingston Card Reader; maxLBA=1995264
TS: Stop validation
TS: Stopped validation
Logging - shut down
--------------------

I don't know if I got it right because I see no LDM information.
"Read and parse LDM information" is checked though...
Reply With Quote
  #4  
Old 20th May 2008
Alexey V. Gubin Alexey V. Gubin is offline
Administrator
 
Join Date: Apr 2007
Posts: 2,977
Send a message via MSN to Alexey V. Gubin
Default Re: Windows software RAID

Looks I explained it badly.

1. Choose "Recover simple volume" mode.
2. When it prompts you to select a physical drive, select any drive which was originally a part of the RAID set, click "Next".

You do not need to try configuring it to recover a RAID.

If this does not help, in "Advanced Configuration" under "General" change "Normal logging" to "Extended logging (for debug purposes)" and retry to see if maybe there is a problem reading or parsing the data.

The correct set of records looks like this (this is a sample I got from my machine):

Code:
Open physical drive 00000101 success, 745 GB : Promise 2+0 Stripe/RAID0 - Port 2, Bus 0, Target 0, LUN 0; maxLBA=1562499968
Open physical drive 00000102 success, 745 GB : Promise 2+0 Stripe/RAID0 - Port 2, Bus 0, Target 1, LUN 0; maxLBA=1562499968
Sector 0, row 1 - 63/240219882 @ base 0 - Win 2000 Dynamic
Sector 0, row 2 - 240219945/1028160 @ base 0 - Win 2000 Dynamic
Sector 0, row 3 - 0/0 @ base 0 - Empty
Sector 0, row 4 - 0/0 @ base 0 - Empty
Ldm: started processing of the device 0100
PRIVHEAD dump
Version       : 02.0B
Disk ID       : dbb12f87-f9d3-49f3-a4a9-358f3a781fac
Host ID       : 1b77da20-c717-11d0-a5be-00a0c91db73c
Disk group ID : 809281d9-47bc-42a5-aaa6-c7aadc3e8607
Disk start    : 63
Disk size     : 241248042, 115 GB
Ldm: device 0100 shift 63
VBLK dump
Group number        : 0x00000050
Record number/Total : 0/1
Data length         : 59
Record type/flags   : 34/00
VBLK type           : Disk
Object ID           : 0416
Object name         : 4469736B35 (Disk5)
Disk object ID (r3) : 64626231326638372D663964332D343966332D613461392D333538663361373831666163 (dbb12f87-f9d3-49f3-a4a9-358f3a781fac)
Disk GUID (r5)      : {00000000-0000-0000-0000-000000000000}
VBLK dump
Group number        : 0x00000002
Record number/Total : 0/1
Data length         : 48
Record type/flags   : 32/00
VBLK type           : Component
Object ID           : 0723
Object name         : 566F6C756D65322D3031 (Volume2-01)
Component type      : 02
Number of children  : 01
Parent ID           : 0721
Sripe size          : 
Number of columns   :
__________________
Best regards,
Alexey
Reply With Quote
  #5  
Old 20th May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Re: Windows software RAID

Ok, second attempt :

--------------------
Init done - logging
NT 5.1.2600 Service Pack 2; 2046 MB RAM
Open physical drive 00000100 success, 38165 MB : WDC WD400BB-75AUA1 - Port 0, Bus 0, Target 0, LUN 0; maxLBA=78163247
Open physical drive 00000101 success, 78166 MB : Maxtor 6Y080M0 - Port 2, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000102 success, 78166 MB : Maxtor 6Y080M0 - Port 3, Bus 0, Target 0, LUN 0; maxLBA=160084415
Open physical drive 00000103 success, 298 GB : Maxtor 3000LE v01.00.00; maxLBA=625140736
Open physical drive 00000104 success, 4032 MB : Kingston DataTravelerCR; maxLBA=8257536
Open physical drive 00000105 success, 974 MB : Kingston Card Reader; maxLBA=1995264
Sector 0, row 1 - 63/160071597 @ base 0 - Win 2000 Dynamic
Sector 0, row 2 - 0/0 @ base 0 - Empty
Sector 0, row 3 - 0/0 @ base 0 - Empty
Sector 0, row 4 - 0/0 @ base 0 - Empty
Ldm: started processing of the device 0100
Ldm: started processing of the device 0101
PRIVHEAD dump
Version : 02.0B
Disk ID : c47295c2-8863-4f42-aac2-eb93c1ad52e3
Host ID : 1b77da20-c717-11d0-a5be-00a0c91db73c
Disk group ID : 58fa1020-ee26-4dad-ad70-11745b157a8e
Disk start : 63
Disk size : 160071597, 78159 MB
Ldm: device 0101 shift 63
Ldm: started processing of the device 0102
PRIVHEAD dump
Version : 02.0B
Disk ID : 05f8193a-ed43-4167-9751-bd5a477dc003
Host ID : 1b77da20-c717-11d0-a5be-00a0c91db73c
Disk group ID : 58fa1020-ee26-4dad-ad70-11745b157a8e
Disk start : 63
Disk size : 160071597, 78159 MB
Ldm: device 0102 shift 63
Ldm: started processing of the device 0103
Ldm: started processing of the device 0104
Bad sector encountered @LBA 8255424 disk 0104
Bad sector encountered @LBA 8255425 disk 0104
Bad sector encountered @LBA 8255426 disk 0104
Bad sector encountered @LBA 8255427 disk 0104
Bad sector encountered @LBA 8255428 disk 0104
Bad sector encountered @LBA 8255429 disk 0104
Bad sector encountered @LBA 8255430 disk 0104
Bad sector encountered @LBA 8255431 disk 0104
Bad sector encountered @LBA 8255432 disk 0104
Bad sector encountered @LBA 8255433 disk 0104
Bad sector encountered @LBA 8255434 disk 0104
Bad sector encountered @LBA 8255435 disk 0104
Bad sector encountered @LBA 8255436 disk 0104
Bad sector encountered @LBA 8255437 disk 0104
Bad sector encountered @LBA 8255438 disk 0104
Bad sector encountered @LBA 8255439 disk 0104
Bad sector encountered @LBA 8255440 disk 0104
Bad sector encountered @LBA 8255441 disk 0104
Bad sector encountered @LBA 8255442 disk 0104
Bad sector encountered @LBA 8255443 disk 0104
Bad sector encountered @LBA 8255444 disk 0104
Bad sector encountered @LBA 8255445 disk 0104
Bad sector encountered @LBA 8255446 disk 0104
Bad sector encountered @LBA 8255447 disk 0104
Bad sector encountered @LBA 8255448 disk 0104
Bad sector encountered @LBA 8255449 disk 0104
Bad sector encountered @LBA 8255450 disk 0104
Bad sector encountered @LBA 8255451 disk 0104
Bad sector encountered @LBA 8255452 disk 0104
Bad sector encountered @LBA 8255453 disk 0104
Bad sector encountered @LBA 8255454 disk 0104
Bad sector encountered @LBA 8255455 disk 0104
Bad sector encountered @LBA 8255456 disk 0104
Bad sector encountered @LBA 8255457 disk 0104
Bad sector encountered @LBA 8255458 disk 0104
Bad sector encountered @LBA 8255459 disk 0104
Bad sector encountered @LBA 8255460 disk 0104
Bad sector encountered @LBA 8255461 disk 0104
Bad sector encountered @LBA 8255462 disk 0104
Bad sector encountered @LBA 8255463 disk 0104
Bad sector encountered @LBA 8255464 disk 0104
Bad sector encountered @LBA 8255465 disk 0104
Bad sector encountered @LBA 8255466 disk 0104
Bad sector encountered @LBA 8255467 disk 0104
Bad sector encountered @LBA 8255468 disk 0104
Bad sector encountered @LBA 8255469 disk 0104
Bad sector encountered @LBA 8255470 disk 0104
Bad sector encountered @LBA 8255471 disk 0104
Bad sector encountered @LBA 8255472 disk 0104
Bad sector encountered @LBA 8255473 disk 0104
Bad sector encountered @LBA 8255474 disk 0104
Bad sector encountered @LBA 8255475 disk 0104
Bad sector encountered @LBA 8255476 disk 0104
Bad sector encountered @LBA 8255477 disk 0104
Bad sector encountered @LBA 8255478 disk 0104
Bad sector encountered @LBA 8255479 disk 0104
Bad sector encountered @LBA 8255480 disk 0104
Bad sector encountered @LBA 8255481 disk 0104
Bad sector encountered @LBA 8255482 disk 0104
Bad sector encountered @LBA 8255483 disk 0104
Bad sector encountered @LBA 8255484 disk 0104
Bad sector encountered @LBA 8255485 disk 0104
Bad sector encountered @LBA 8255486 disk 0104
Bad sector encountered @LBA 8255487 disk 0104
Ldm: started processing of the device 0105
TS: Stop validation
TS: Stopped validation
Logging - shut down
--------------------

There seem to be bad sectors but they belong to external HD (device 104) not the array.
Reply With Quote
  #6  
Old 20th May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Re: Windows software RAID

Do you need me to activate the "Extended logging (for debug purposes)" ?

I will try it tonight and unplug the external HD too...
Reply With Quote
  #7  
Old 21st May 2008
Alexey V. Gubin Alexey V. Gubin is offline
Administrator
 
Join Date: Apr 2007
Posts: 2,977
Send a message via MSN to Alexey V. Gubin
Default Re: Windows software RAID

Nope. I'm still doing some tests locally. Be back to you in about 12-18 hours.
__________________
Best regards,
Alexey
Reply With Quote
  #8  
Old 21st May 2008
Alexey V. Gubin Alexey V. Gubin is offline
Administrator
 
Join Date: Apr 2007
Posts: 2,977
Send a message via MSN to Alexey V. Gubin
Default Re: Windows software RAID

Is it possible to get the system back on the old mainboard?
__________________
Best regards,
Alexey
Reply With Quote
  #9  
Old 21st May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Re: Windows software RAID

Well, technicaly it would be possible...

The problem is with Windows XP Pro :
After the change of mainboard, I had to boot from the WIN XP CDROM (genuine and original) and repair the current installation. And after completing this, Windows needed to undergo the process of Activation. If possible, I want to avoid another activation in such a short time.

I could "ghost" the current system partition, change back the mainboard, restore my previous "ghosted" and activated system partition (compatible with the old mainboard) ...

But I'm currently trying something else. I think I got the order of the SATA disks wrong.

I noticed that all the correctly restored files where very small (less than 1K), the others are "corrupted". I think the correct files were all "embedded" in the MFTs. That gave me a clue that I may have swapped the disks when plugging the cables to the mainboard...

I'm trying to create an image of the Raid-0 with the order of disks inverted. After that I will let ZAR find and restore what it can.

I will let you know ! :-)
Reply With Quote
  #10  
Old 22nd May 2008
csantos csantos is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Default Re: Windows software RAID

Well, it seems to work !

The recovered files from the 1st partition (20 GB) look ok.
.EXE are working, .LOG and .TXT are readable, filesystem structure looks like it was before ... :-)

I thank you for the attention and for the time spent on my case !!

If you need some more information, I will gladly provide it !

Thank you again !
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Software RAID-5 Recovery bsnaukensu ZAR 5 16th July 2009 08:27
New user here. :) ... need to recover lost photos from Canon ZoomBrowser EX software zebrastripe ZAR 3 1st May 2008 00:53
Promise Raid recovery dougcollins ZAR 18 17th January 2008 04:44
Windows won't load wildkt66 ZAR 1 24th December 2007 14:05
Cannot Get Into Windows to Install ZAR GeorgeJefferson ZAR 1 12th June 2007 13:06


All times are GMT -8. The time now is 08:07.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
(c) Zero Assumption Software